hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8394) Move getAdditionalBlock() and related functionalities into a separate class
Date Mon, 18 May 2015 17:52:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8394?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14548397#comment-14548397
] 

Konstantin Shvachko commented on HDFS-8394:
-------------------------------------------

I was wondering what is the reason for such refactorings?
It is quite strange: with all static methods you basically introduce C-style coding practice.
What is wrong with OOP?

> Move getAdditionalBlock() and related functionalities into a separate class
> ---------------------------------------------------------------------------
>
>                 Key: HDFS-8394
>                 URL: https://issues.apache.org/jira/browse/HDFS-8394
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>             Fix For: 2.8.0
>
>         Attachments: HDFS-8394.000.patch, HDFS-8394.001.patch, HDFS-8394.002.patch, HDFS-8394.003.patch,
HDFS-8394.004.patch, HDFS-8394.005.patch, HDFS-8394.006.patch
>
>
> This jira proposes to move the implementation of getAdditionalBlock() and related functionalities
to a separate class to open up the possibilities of further refactoring and improvements.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message