hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8394) Move getAdditionalBlock() and related functionalities into a separate class
Date Sat, 16 May 2015 11:36:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8394?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14546706#comment-14546706
] 

Hudson commented on HDFS-8394:
------------------------------

FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #198 (See [https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/198/])
HDFS-8394. Move getAdditionalBlock() and related functionalities into a separate class. Contributed
by Haohui Mai. (wheat9: rev e5afac5896a1a88e152746598527d91f73cbb724)
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirWriteFileOp.java
* hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCommitBlockSynchronization.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NameNodeRpcServer.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestAddBlockRetry.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSEditLogLoader.java


> Move getAdditionalBlock() and related functionalities into a separate class
> ---------------------------------------------------------------------------
>
>                 Key: HDFS-8394
>                 URL: https://issues.apache.org/jira/browse/HDFS-8394
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>             Fix For: 2.8.0
>
>         Attachments: HDFS-8394.000.patch, HDFS-8394.001.patch, HDFS-8394.002.patch, HDFS-8394.003.patch,
HDFS-8394.004.patch, HDFS-8394.005.patch, HDFS-8394.006.patch
>
>
> This jira proposes to move the implementation of getAdditionalBlock() and related functionalities
to a separate class to open up the possibilities of further refactoring and improvements.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message