hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yi Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8255) Rename getBlockReplication to getPreferredBlockReplication
Date Tue, 12 May 2015 05:17:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8255?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14539259#comment-14539259
] 

Yi Liu commented on HDFS-8255:
------------------------------

Thanks Zhe for rebase, I will commit after passing a fresh Jenkins.

> Rename getBlockReplication to getPreferredBlockReplication
> ----------------------------------------------------------
>
>                 Key: HDFS-8255
>                 URL: https://issues.apache.org/jira/browse/HDFS-8255
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.8.0
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>              Labels: BB2015-05-TBR
>         Attachments: HDFS-8255.000.patch, HDFS-8255.001.patch, HDFS-8255.002.patch
>
>
> We should rename {{BlockCollection#getBlockReplication}} to {{getPreferredBlockStorageNum}}
for 2 reasons:
> # Currently, this method actually returns the _preferred_ block replication factor instead
of the _actual_ number of replicas. The current name is a little ambiguous. {{getPreferredBlockStorageNum}}
is also consistent with {{getPreferredBlockSize}}
> # With the erasure coding feature, the name doesn't apply to striped blocks. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message