hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-8255) Rename getBlockReplication to getPreferredBlockStorageNum
Date Tue, 05 May 2015 20:28:00 GMT

     [ https://issues.apache.org/jira/browse/HDFS-8255?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Zhe Zhang updated HDFS-8255:
----------------------------
    Affects Version/s: 2.8.0

> Rename getBlockReplication to getPreferredBlockStorageNum
> ---------------------------------------------------------
>
>                 Key: HDFS-8255
>                 URL: https://issues.apache.org/jira/browse/HDFS-8255
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.8.0
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8255.000.patch, HDFS-8255.001.patch
>
>
> We should rename {{BlockCollection#getBlockReplication}} to {{getPreferredBlockStorageNum}}
for 2 reasons:
> # Currently, this method actually returns the _preferred_ block replication factor instead
of the _actual_ number of replicas. The current name is a little ambiguous. {{getPreferredBlockStorageNum}}
is also consistent with {{getPreferredBlockSize}}
> # With the erasure coding feature, the name doesn't apply to striped blocks. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message