hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8255) Rename getBlockReplication to getPreferredBlockStorageNum
Date Tue, 05 May 2015 17:45:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8255?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14528882#comment-14528882
] 

Andrew Wang commented on HDFS-8255:
-----------------------------------

Seems like use of this field is overloaded in EC to mean something else. Not sure how I feel
about that, since it seems like it precludes EC+replication (something we should be able to
support).

I like renaming to "getPreferredReplication" for your reason #1, maybe for #2 we introduce
a new striping/EC-specific field.

> Rename getBlockReplication to getPreferredBlockStorageNum
> ---------------------------------------------------------
>
>                 Key: HDFS-8255
>                 URL: https://issues.apache.org/jira/browse/HDFS-8255
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8255.000.patch
>
>
> We should rename {{BlockCollection#getBlockReplication}} to {{getPreferredBlockStorageNum}}
for 2 reasons:
> # Currently, this method actually returns the _preferred_ block replication factor instead
of the _actual_ number of replicas. The current name is a little ambiguous. {{getPreferredBlockStorageNum}}
is also consistent with {{getPreferredBlockSize}}
> # With the erasure coding feature, the name doesn't apply to striped blocks. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message