hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8255) Rename getBlockReplication to getPreferredBlockReplication
Date Wed, 13 May 2015 14:28:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8255?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14541997#comment-14541997
] 

Hudson commented on HDFS-8255:
------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #184 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/184/])
HDFS-8255. Rename getBlockReplication to getPreferredBlockReplication. (Contributed by Zhe
Zhang) (yliu: rev 6d5da9484185ca9f585195d6da069b9cd5be4044)
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirConcatOp.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSEditLogLoader.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/snapshot/TestSnapshotDeletion.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockManager.java
* hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/snapshot/TestFileWithSnapshotFeature.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DecommissionManager.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockCollection.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestReplicationPolicy.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirAttrOp.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/snapshot/FileWithSnapshotFeature.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockManager.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/BlockInfoContiguous.java
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/snapshot/TestSnapshotReplication.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeFile.java


> Rename getBlockReplication to getPreferredBlockReplication
> ----------------------------------------------------------
>
>                 Key: HDFS-8255
>                 URL: https://issues.apache.org/jira/browse/HDFS-8255
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.8.0
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>              Labels: BB2015-05-TBR
>             Fix For: 2.8.0
>
>         Attachments: HDFS-8255.000.patch, HDFS-8255.001.patch, HDFS-8255.002.patch
>
>
> We should rename {{BlockCollection#getBlockReplication}} to {{getPreferredBlockStorageNum}}
for 2 reasons:
> # Currently, this method actually returns the _preferred_ block replication factor instead
of the _actual_ number of replicas. The current name is a little ambiguous. {{getPreferredBlockStorageNum}}
is also consistent with {{getPreferredBlockSize}}
> # With the erasure coding feature, the name doesn't apply to striped blocks. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message