hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4838) HDFS should use the new methods added in HADOOP-9574
Date Wed, 13 May 2015 01:10:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4838?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14541145#comment-14541145
] 

Hadoop QA commented on HDFS-4838:
---------------------------------

\\
\\
| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | pre-patch |  14m 37s | Pre-patch trunk compilation is healthy. |
| {color:green}+1{color} | @author |   0m  0s | The patch does not contain any @author tags.
|
| {color:red}-1{color} | tests included |   0m  0s | The patch doesn't appear to include any
new or modified tests.  Please justify why no new tests are needed for this patch. Also please
list what manual steps were performed to verify this patch. |
| {color:green}+1{color} | javac |   7m 27s | There were no new javac warning messages. |
| {color:green}+1{color} | javadoc |   9m 41s | There were no new javadoc warning messages.
|
| {color:green}+1{color} | release audit |   0m 23s | The applied patch does not increase
the total number of release audit warnings. |
| {color:green}+1{color} | checkstyle |   2m 12s | There were no new checkstyle issues. |
| {color:green}+1{color} | whitespace |   0m  0s | The patch has no lines that end in whitespace.
|
| {color:green}+1{color} | install |   1m 32s | mvn install still works. |
| {color:green}+1{color} | eclipse:eclipse |   0m 33s | The patch built with eclipse:eclipse.
|
| {color:green}+1{color} | findbugs |   3m  3s | The patch does not introduce any new Findbugs
(version 2.0.3) warnings. |
| {color:green}+1{color} | native |   3m 13s | Pre-build of native portion |
| {color:red}-1{color} | hdfs tests | 164m 30s | Tests failed in hadoop-hdfs. |
| | | 207m 15s | |
\\
\\
|| Reason || Tests ||
| Failed unit tests | hadoop.tracing.TestTraceAdmin |
|   | hadoop.hdfs.server.namenode.TestFileTruncate |
|   | hadoop.tools.TestHdfsConfigFields |
\\
\\
|| Subsystem || Report/Notes ||
| Patch URL | http://issues.apache.org/jira/secure/attachment/12709289/HDFS-4838.patch |
| Optional Tests | javadoc javac unit findbugs checkstyle |
| git revision | trunk / f24452d |
| hadoop-hdfs test log | https://builds.apache.org/job/PreCommit-HDFS-Build/10937/artifact/patchprocess/testrun_hadoop-hdfs.txt
|
| Test Results | https://builds.apache.org/job/PreCommit-HDFS-Build/10937/testReport/ |
| Java | 1.7.0_55 |
| uname | Linux asf907.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep
3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux |
| Console output | https://builds.apache.org/job/PreCommit-HDFS-Build/10937/console |


This message was automatically generated.

> HDFS should use the new methods added in HADOOP-9574
> ----------------------------------------------------
>
>                 Key: HDFS-4838
>                 URL: https://issues.apache.org/jira/browse/HDFS-4838
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.7.0
>            Reporter: Jian He
>            Assignee: Dongming Liang
>         Attachments: HDFS-4838.patch
>
>
> HADOOP-9574 copies addPersistedDelegationToken in hdfs.DelegationTokenSecretManager to
common.AbstractDelegationTokenSecretManager. HDFS code should be removed and should instead
use the code in common.
> Also, Is it possible to rename logUpdateMasterKey to storeNewMasterKey AND logExpireToken
to removeStoredToken for persisting and recovering keys/tokens?
> These methods are likely to be common methods and be used by overridden secretManager.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message