hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8255) Rename getBlockReplication to getPreferredBlockStorageNum
Date Sun, 26 Apr 2015 09:25:38 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8255?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14512954#comment-14512954
] 

Hadoop QA commented on HDFS-8255:
---------------------------------

\\
\\
| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | pre-patch |  15m  6s | Pre-patch trunk compilation is healthy. |
| {color:green}+1{color} | @author |   0m  0s | The patch does not contain any @author tags.
|
| {color:green}+1{color} | tests included |   0m  0s | The patch appears to include 4 new
or modified test files. |
| {color:green}+1{color} | whitespace |   0m  0s | The patch has no lines that end in whitespace.
|
| {color:green}+1{color} | javac |   7m 44s | There were no new javac warning messages. |
| {color:green}+1{color} | javadoc |   9m 52s | There were no new javadoc warning messages.
|
| {color:green}+1{color} | release audit |   0m 22s | The applied patch does not increase
the total number of release audit warnings. |
| {color:red}-1{color} | checkstyle |   5m 33s | The applied patch generated  2  additional
checkstyle issues. |
| {color:green}+1{color} | install |   1m 35s | mvn install still works. |
| {color:green}+1{color} | eclipse:eclipse |   0m 32s | The patch built with eclipse:eclipse.
|
| {color:green}+1{color} | findbugs |   3m 13s | The patch does not introduce any new Findbugs
(version 2.0.3) warnings. |
| {color:green}+1{color} | native |   3m 20s | Pre-build of native portion |
| {color:green}+1{color} | hdfs tests | 167m 25s | Tests passed in hadoop-hdfs. |
| | | 214m 47s | |
\\
\\
|| Subsystem || Report/Notes ||
| Patch URL | http://issues.apache.org/jira/secure/attachment/12728210/HDFS-8255.000.patch
|
| Optional Tests | javadoc javac unit findbugs checkstyle |
| git revision | trunk / 22b70e7 |
| checkstyle | https://builds.apache.org/job/PreCommit-HDFS-Build/10396/artifact/patchprocess/checkstyle-result-diff.txt
|
| hadoop-hdfs test log | https://builds.apache.org/job/PreCommit-HDFS-Build/10396/artifact/patchprocess/testrun_hadoop-hdfs.txt
|
| Test Results | https://builds.apache.org/job/PreCommit-HDFS-Build/10396/testReport/ |
| Console output | https://builds.apache.org/job/PreCommit-HDFS-Build/10396/console |


This message was automatically generated.

> Rename getBlockReplication to getPreferredBlockStorageNum
> ---------------------------------------------------------
>
>                 Key: HDFS-8255
>                 URL: https://issues.apache.org/jira/browse/HDFS-8255
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8255.000.patch
>
>
> We should rename {{BlockCollection#getBlockReplication}} to {{getPreferredBlockStorageNum}}
for 2 reasons:
> # Currently, this method actually returns the _preferred_ block replication factor instead
of the _actual_ number of replicas. The current name is a little ambiguous. {{getPreferredBlockStorageNum}}
is also consistent with {{getPreferredBlockSize}}
> # With the erasure coding feature, the name doesn't apply to striped blocks. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message