hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uma Maheswara Rao G (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8146) Protobuf changes for BlockECRecoveryCommand and its fields for making it ready for transfer to DN
Date Sat, 18 Apr 2015 15:49:59 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8146?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14501428#comment-14501428

Uma Maheswara Rao G commented on HDFS-8146:

Thanks Vinay for the review!
 {quote}Currently BlockCommand's targetStorageIDs are not used otherthan in tests.{quote}
If we really not useful then surely we can refine it later. I think right now its ok to keep

2. final static int DNA_ERASURE_CODE = 11; // erasure coding recovery command whether this
is enough for the recovery command.? What if name it as DNA_ERASURE_CODE_RECOVERY ? 
I am ok to have the name as DNA_ERASURE_CODE_RECOVERY . It make sense. Right now in this phase,
I think this should be enough IMO.  Later when we support fresh conversions, then we can handle
them by action enums.

Will upload the patch shortly by changing command name from DNA_ERASURE_CODE  to DNA_ERASURE_CODE_RECOVERY

> Protobuf changes for BlockECRecoveryCommand and its fields for making it ready for transfer
to DN 
> --------------------------------------------------------------------------------------------------
>                 Key: HDFS-8146
>                 URL: https://issues.apache.org/jira/browse/HDFS-8146
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Uma Maheswara Rao G
>            Assignee: Uma Maheswara Rao G
>         Attachments: HDFS-8146-1.patch, HDFS-8146.0.patch
> As part of working on HDFS-8137, we need to prepare BlockECRecoveryCommand, BlockECRecoveryInfo,
DatanodeStorageInfo, DatanodeDescripter (We can use DatanodeInfo for proto trasfer)  should
be ready in proto format for transferring them in command. Since all this code could be straight
forward and to have better focussed review on core part, I propose to separate this part in
to this JIRA. First I will prepare all this supported classes protobuf ready and then trasnfer
them to DN as part of HDFS-8137 by including ECSchema.

This message was sent by Atlassian JIRA

View raw message