hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daryn Sharp (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-8133) Improve readability of deleted block check
Date Mon, 13 Apr 2015 16:12:12 GMT
Daryn Sharp created HDFS-8133:

             Summary: Improve readability of deleted block check
                 Key: HDFS-8133
                 URL: https://issues.apache.org/jira/browse/HDFS-8133
             Project: Hadoop HDFS
          Issue Type: Improvement
          Components: namenode
    Affects Versions: 2.0.0-alpha
            Reporter: Daryn Sharp
            Assignee: Daryn Sharp

The current means of checking if a block is deleted is checking if its block collection is
null.  A more readable approach is an isDeleted method.

This message was sent by Atlassian JIRA

View raw message