hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo Nicholas Sze (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8129) Maintain consistent naming for Erasure Coding related classes - EC/ErasureCode
Date Fri, 17 Apr 2015 20:22:59 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8129?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14500592#comment-14500592
] 

Tsz Wo Nicholas Sze commented on HDFS-8129:
-------------------------------------------

ErasureCoding* sounds good.  For the classes are already in the erasurecode package, EcXxx
is good enough.

> Maintain consistent naming for Erasure Coding related classes - EC/ErasureCode
> ------------------------------------------------------------------------------
>
>                 Key: HDFS-8129
>                 URL: https://issues.apache.org/jira/browse/HDFS-8129
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Uma Maheswara Rao G
>            Assignee: Uma Maheswara Rao G
>            Priority: Minor
>
> Currently I see some classes named as ErasureCode* and some are with EC*
> I feel we should maintain consistent naming across project. This jira to correct the
places where we named differently to be a unique.
> And also to discuss which naming we can follow from now onwards when we create new classes.

> ErasureCoding* should be fine IMO. Lets discuss what others feel.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message