hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uma Maheswara Rao G (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HDFS-8129) Erasure Coding: Maintain consistent naming for Erasure Coding related classes - EC/ErasureCoding
Date Wed, 29 Apr 2015 14:06:07 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8129?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14519385#comment-14519385
] 

Uma Maheswara Rao G edited comment on HDFS-8129 at 4/29/15 2:05 PM:
--------------------------------------------------------------------

I think EcXxx would be right naming. But right now we follow both patterns in our code( example:
FSNamesystem, FsDatasetImpl). So, sure we can discuss on it and finalize here which way we
could follow in Ec work as it may be right time to control.


was (Author: umamaheswararao):
I think EcXxx would be right naming. But right now we follow both patterns in our code. So,
sure we can discuss on it and finalize here which way we could follow in Ec work as it may
be right time to control.

> Erasure Coding: Maintain consistent naming for Erasure Coding related classes - EC/ErasureCoding
> ------------------------------------------------------------------------------------------------
>
>                 Key: HDFS-8129
>                 URL: https://issues.apache.org/jira/browse/HDFS-8129
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Uma Maheswara Rao G
>            Assignee: Uma Maheswara Rao G
>            Priority: Minor
>
> Currently I see some classes named as ErasureCode* and some are with EC*
> I feel we should maintain consistent naming across project. This jira to correct the
places where we named differently to be a unique.
> And also to discuss which naming we can follow from now onwards when we create new classes.

> ErasureCoding* should be fine IMO. Lets discuss what others feel.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message