hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rakesh R (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8129) Erasure Coding: Maintain consistent naming for Erasure Coding related classes - EC/ErasureCoding
Date Wed, 29 Apr 2015 11:21:06 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8129?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14519149#comment-14519149
] 

Rakesh R commented on HDFS-8129:
--------------------------------

I'm adding few more classes for the discussion, please see:
{code}
org.apache.hadoop.io.erasurecode.ECChunk
org.apache.hadoop.io.erasurecode.ECBlockGroup
org.apache.hadoop.io.erasurecode.ECBlock
org.apache.hadoop.io.erasurecode.ECSchema
{code}

> Erasure Coding: Maintain consistent naming for Erasure Coding related classes - EC/ErasureCoding
> ------------------------------------------------------------------------------------------------
>
>                 Key: HDFS-8129
>                 URL: https://issues.apache.org/jira/browse/HDFS-8129
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Uma Maheswara Rao G
>            Assignee: Uma Maheswara Rao G
>            Priority: Minor
>
> Currently I see some classes named as ErasureCode* and some are with EC*
> I feel we should maintain consistent naming across project. This jira to correct the
places where we named differently to be a unique.
> And also to discuss which naming we can follow from now onwards when we create new classes.

> ErasureCoding* should be fine IMO. Lets discuss what others feel.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message