hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8117) More accurate verification in SimulatedFSDataset: replace DEFAULT_DATABYTE with patterned data
Date Mon, 13 Apr 2015 19:05:12 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14492869#comment-14492869
] 

Andrew Wang commented on HDFS-8117:
-----------------------------------

Couple comments:

* I still see a raw {{12}} that's not a variable, though it's better now. Name it {{numBlocksPerFile}}?
* I have the same comment as Kai above about the forloop. Maybe we add a helper function to
DFSTestUtil that takes a LocatedBlocks? Will make usage in the tests more convenient for sure.

Otherwise good though, +1 pending.

> More accurate verification in SimulatedFSDataset: replace DEFAULT_DATABYTE with patterned
data
> ----------------------------------------------------------------------------------------------
>
>                 Key: HDFS-8117
>                 URL: https://issues.apache.org/jira/browse/HDFS-8117
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8117.000.patch, HDFS-8117.001.patch, HDFS-8117.002.patch
>
>
> Currently {{SimulatedFSDataset}} uses a single {{DEFAULT_DATABYTE}} to simulate _all_
block content. This is not accurate because the return of this byte just means the read request
has hit an arbitrary position in an arbitrary simulated block.
> This JIRA aims to improve it with a more accurate verification. When position {{p}} of
a simulated block {{b}} is accessed, the returned byte is {{b}}'s block ID plus {{p}}, moduled
by the max value of a byte.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message