hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-8076) Code cleanup for DFSInputStream: use offset instead of LocatedBlock when possible
Date Wed, 08 Apr 2015 22:42:13 GMT

    [ https://issues.apache.org/jira/browse/HDFS-8076?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14486242#comment-14486242
] 

Zhe Zhang commented on HDFS-8076:
---------------------------------

Thanks Andrew for the review!

> Code cleanup for DFSInputStream: use offset instead of LocatedBlock when possible
> ---------------------------------------------------------------------------------
>
>                 Key: HDFS-8076
>                 URL: https://issues.apache.org/jira/browse/HDFS-8076
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8076-000.patch
>
>
> This JIRA aims to refactor the signatures {{fetchBlockByteRange}} and {{actualGetFromOneDataNode}}.
Instead of taking a {{LocatedBlock}}, I think they should just take the starting offset of
that block, since they'll later call {{getBlockAt}} to refresh the location anyway. I think
we should make it clear so the callers are not surprised if the finally used {{LocatedBlock}}
is not the one they passed in. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message