hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-8033) Erasure coding: stateful (non-positional) read from files in striped layout
Date Thu, 23 Apr 2015 00:53:38 GMT

     [ https://issues.apache.org/jira/browse/HDFS-8033?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Zhe Zhang updated HDFS-8033:
----------------------------
    Attachment: HDFS-8033.003.patch

The 003 patch addresses Jing's comments.

# It keeps the {{blockSeekTo}} name and just changes the signature. [~jingzhao] does this
look OK to you?
# The new {{readBuffer}} method simplifies the retry logic from the super method, and only
keeps the part of retrying same located block.
# I'm not so sure if the logic of switching between block readers should belong to {{readWithStrategy}}
or {{readBuffer}}. It only matters for readability I guess.

> Erasure coding: stateful (non-positional) read from files in striped layout
> ---------------------------------------------------------------------------
>
>                 Key: HDFS-8033
>                 URL: https://issues.apache.org/jira/browse/HDFS-8033
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>         Attachments: HDFS-8033.000.patch, HDFS-8033.001.patch, HDFS-8033.002.patch, HDFS-8033.003.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message