hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7955) Improve naming of classes, methods, and variables related to block replication and recovery
Date Mon, 06 Apr 2015 23:29:13 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7955?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14482200#comment-14482200
] 

Zhe Zhang commented on HDFS-7955:
---------------------------------

[~rakeshr] Thanks for the question. Yes I will create a separate JIRA for the 2nd point in
the description. 

Also, regarding the 1st point, Jing, Nicholas, and I agreed that it's better to rename EC-related
block repair logic to "reconstruction". Does it sound good to you?

> Improve naming of classes, methods, and variables related to block replication and recovery
> -------------------------------------------------------------------------------------------
>
>                 Key: HDFS-7955
>                 URL: https://issues.apache.org/jira/browse/HDFS-7955
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Zhe Zhang
>            Assignee: Rakesh R
>
> Many existing names should be revised to avoid confusion when blocks can be both replicated
and erasure coded. This JIRA aims to solicit opinions on making those names more consistent
and intuitive.
> # In current HDFS _block recovery_ refers to the process of finalizing the last block
of a file, triggered by _lease recovery_. It is different from the intuitive meaning of _recovering
a lost block_. To avoid confusion, I can think of 2 options:
> #* Rename this process as _block finalization_ or _block completion_. I prefer this option
because this is literally not a recovery.
> #* If we want to keep existing terms unchanged we can name all EC recovery and re-replication
logics as _reconstruction_.  
> # As Kai [suggested | https://issues.apache.org/jira/browse/HDFS-7369?focusedCommentId=14361131&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14361131]
under HDFS-7369, several replication-based names should be made more generic:
> #* {{UnderReplicatedBlocks}} and {{neededReplications}}. E.g. we can use {{LowRedundancyBlocks}}/{{AtRiskBlocks}},
and {{neededRecovery}}/{{neededReconstruction}}.
> #* {{PendingReplicationBlocks}}
> #* {{ReplicationMonitor}}
> I'm sure the above list is incomplete; discussions and comments are very welcome.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message