hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7937) Erasure Coding: INodeFile quota computation unit tests
Date Wed, 08 Apr 2015 18:11:14 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7937?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14485677#comment-14485677
] 

Zhe Zhang commented on HDFS-7937:
---------------------------------

Thanks for the update Kai! The patch looks good overall. A few minor issues:
# Maybe {{TestStripedINodeFile}} is a better name?
# 2 empty lines after all imports
# Would be better to have a {{\@After}} method
# Since you have a {{testDir}}, {{testPath}} can just be "foo" (if I remember correctly).
{code}
final Path ECFilePath = new Path(testDir, testPath);
{code}
# Some assertion values are hard-coded. It'd be better to connect to HdfsConstants
#* 196609 (now it fails because default cell size has been changed to 128K
#* 6 data blocks and 3 parity blocks
# Would be great if we can cover more scenarios. E.g., what if the striped block crosses multiple
cells and multiple stripes. What if the file has multiple striped blocks.

> Erasure Coding: INodeFile quota computation unit tests
> ------------------------------------------------------
>
>                 Key: HDFS-7937
>                 URL: https://issues.apache.org/jira/browse/HDFS-7937
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Kai Sasaki
>            Assignee: Kai Sasaki
>            Priority: Minor
>         Attachments: HDFS-7937.1.patch, HDFS-7937.2.patch, HDFS-7937.3.patch, HDFS-7937.4.patch,
HDFS-7937.5.patch
>
>
> Unit test for [HDFS-7826|https://issues.apache.org/jira/browse/HDFS-7826]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message