hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinayakumar B (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7889) Subclass DFSOutputStream to support writing striping layout files
Date Thu, 02 Apr 2015 06:55:54 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7889?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14392245#comment-14392245

Vinayakumar B commented on HDFS-7889:

Hi [~libo-intel], 
thanks for the nice work.
Here are some comments

I didn't understand this part. Why catching InterruptedException?
      try {
        cellBuffers[i] = ByteBuffer.wrap(byteArrayManager.newByteArray(cellSize));
      } catch (InterruptedException ie) {
        cellBuffers[i] = ByteBuffer.allocate(cellSize);

I think below part of the code never needed. Because {{BufferOverflowException}} is thrown
in {{addToCellBuffer}} itself.
{code}    } else if (getSizeOfCellnBuffer(curIdx) > cellSize) {
      String msg = "Writing a chunk should not overflow buffer.";
      throw new IOException(msg);

{{clearCellBuffers(int index)}} not required, atleast as of now.

{{getPaddingBytes}} can be renamed to {{getNumPaddingBytes}} as this is the size rather than
bytes itself.

In {{StripedDataStreamer}} constructor, below comment looks unrelated
{code}  /**
   * construction with tracing info

> Subclass DFSOutputStream to support writing striping layout files
> -----------------------------------------------------------------
>                 Key: HDFS-7889
>                 URL: https://issues.apache.org/jira/browse/HDFS-7889
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Li Bo
>            Assignee: Li Bo
>         Attachments: HDFS-7889-001.patch, HDFS-7889-002.patch, HDFS-7889-003.patch, HDFS-7889-004.patch,
HDFS-7889-005.patch, HDFS-7889-006.patch
> After HDFS-7888, we can subclass  {{DFSOutputStream}} to support writing striping layout

This message was sent by Atlassian JIRA

View raw message