hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Walter Su (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-7973) rename favoriteAndExcludedNodes to excludedNodes for clarity
Date Mon, 23 Mar 2015 12:28:11 GMT

     [ https://issues.apache.org/jira/browse/HDFS-7973?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Walter Su updated HDFS-7973:
----------------------------
    Status: Patch Available  (was: Open)

> rename favoriteAndExcludedNodes to excludedNodes for clarity
> ------------------------------------------------------------
>
>                 Key: HDFS-7973
>                 URL: https://issues.apache.org/jira/browse/HDFS-7973
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Walter Su
>            Assignee: Walter Su
>            Priority: Minor
>         Attachments: HDFS-7973.001.patch
>
>
> two reasons:
> 1. name {{favoriteAndExcludedNodes}} is easily confusing.
> 2. {{DatanodeStorageInfo[] chooseTarget(..)}} should like {{private Node chooseTarget(..)}}
use name {{oldExcludedNodes}} to backup {{excludedNodes}}. We should keep the consistency.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message