hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HDFS-1522) Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant
Date Wed, 04 Mar 2015 02:36:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-1522?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14346269#comment-14346269
] 

Konstantin Shvachko edited comment on HDFS-1522 at 3/4/15 2:35 AM:
-------------------------------------------------------------------

Hey Dongming. Glad you've picked this up.
The patch looks good. A few comments:
# In {{RemoteBlockReader}} the line you changed is longer than 80 characters.
# Also check a couple other places where your change made long lines.
# We should avoid {{import ...*}} pattern, which I see in {{TestReplication}}.
In general, import changes should be kept at minimum to reduce conflicts with other branches.

Once you attach a new patch you should use "submit patch" button to trigger a Jenkins build.


was (Author: shv):
Hey Dongming. Glad you've picked this up.
The patch looks good. A few comments:
# In {{RemoteBlockReader}} the line you changed is longer than 80 characters.
# Also check a couple other places where your change made long lines.
# We should avoid {{import ...*}} pattern, which I see in {{TestReplication}}.
In general, import changes should be kept at minimum to reduce conflicts with other branches.

Once you submit new patch you should use "submit patch" button to trigger a Jenkins build.

> Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant
> ---------------------------------------------------------------------------------
>
>                 Key: HDFS-1522
>                 URL: https://issues.apache.org/jira/browse/HDFS-1522
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: datanode
>    Affects Versions: 0.21.0
>            Reporter: Konstantin Shvachko
>            Assignee: Dongming Liang
>         Attachments: HDFS-1522.patch
>
>
> Two semantically identical constant {{Block.BLOCK_FILE_PREFIX}} and {{DataStorage.BLOCK_FILE_PREFIX}}
should merged into one. Should be defined in {{Block}}, imo.
> Also use cases of "blok_", like in {{DirectoryScanner}} should be replaced by the this
constant.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message