hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dongming Liang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-1522) Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant
Date Wed, 04 Mar 2015 21:09:38 GMT

     [ https://issues.apache.org/jira/browse/HDFS-1522?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dongming Liang updated HDFS-1522:
---------------------------------
        Fix Version/s: 3.0.0
               Labels: patch  (was: )
     Target Version/s: 3.0.0  (was: 2.7.0)
    Affects Version/s:     (was: 0.21.0)
                       3.0.0
         Release Note: 
This merges Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant. Hard-coded
literals of "blk_" in various files are also updated to use the same constant. 
         Hadoop Flags: Reviewed
               Status: Patch Available  (was: In Progress)

Existing test cases are used for testing. The code changes are reviewed by Konstantin Shvachko.

> Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant
> ---------------------------------------------------------------------------------
>
>                 Key: HDFS-1522
>                 URL: https://issues.apache.org/jira/browse/HDFS-1522
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: datanode
>    Affects Versions: 3.0.0
>            Reporter: Konstantin Shvachko
>            Assignee: Dongming Liang
>              Labels: patch
>             Fix For: 3.0.0
>
>         Attachments: HDFS-1522.002.patch, HDFS-1522.patch
>
>
> Two semantically identical constant {{Block.BLOCK_FILE_PREFIX}} and {{DataStorage.BLOCK_FILE_PREFIX}}
should merged into one. Should be defined in {{Block}}, imo.
> Also use cases of "blok_", like in {{DirectoryScanner}} should be replaced by the this
constant.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message