hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7778) Rename FsVolumeListTest to TestFsVolumeList and commit it to branch-2
Date Wed, 11 Feb 2015 23:37:12 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7778?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14317212#comment-14317212
] 

Chris Nauroth commented on HDFS-7778:
-------------------------------------

Hi [~eddyxu].  I think I'm fully caught up now on why there are differences between trunk
and branch-2.  The branch-2 patch you posted is pulling in a piece of HDFS-7430.  That one
was committed to trunk only.  I see a comment in there that the intention was to let it bake
in trunk for a week or two before merging to branch-2.  I'm going to ask now if it's time
to proceed with that merge.

I'd like to suggest that we put this jira on hold while we figure out the timing of the HDFS-7430
merge.  Then, I expect you'll be able to put together test-only patches (maybe even the same
patch for trunk and branch-2) to do the test suite renaming.  After that, I'd proceed with
rebasing HDFS-7604, again hopefully without requiring separate patches for each branch.

I'd prefer not to commit the current branch-2 patch posted here, because pulling in just a
small piece of HDFS-7430 would create a confusing situation later for the full merge of HDFS-7430.

Thanks for your help on this!

> Rename FsVolumeListTest to TestFsVolumeList and commit it to branch-2
> ---------------------------------------------------------------------
>
>                 Key: HDFS-7778
>                 URL: https://issues.apache.org/jira/browse/HDFS-7778
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: datanode
>    Affects Versions: 2.6.0
>            Reporter: Lei (Eddy) Xu
>            Assignee: Lei (Eddy) Xu
>         Attachments: HDFS-7778-branch2.000.patch, HDFS-7778-trunk.000.patch
>
>
> HDFS-7496 mistakenly named {{FsVolumeListTest}}, which causes it out of jenkin tests.
Also it mistakenly removed it from branch-2 patch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message