hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lei (Eddy) Xu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-7778) Rename FsVolumeListTest to TestFsVolumeList and commit it to branch-2
Date Wed, 11 Feb 2015 21:11:11 GMT

     [ https://issues.apache.org/jira/browse/HDFS-7778?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lei (Eddy) Xu updated HDFS-7778:
--------------------------------
    Attachment: HDFS-7778-branch2.000.patch

Revised branch-2 patch. I did following changes:

1. Use {{git diff trunk -- **/FsVolumeList.java}} and etc to backport all diffs related to
{{FsVolumeReference}} to branch-2 {{FsVolumeList/FsDatasetImpl/TestFsVolumeList/TestFsDatasetImpl}}.
2. Add the following line:

{code:title=FsVolumeList#addVolume()}
    IOUtils.cleanup(null, ref);
    FsDatasetImpl.LOG.info("Added new volume: " +
        ref.getVolume().getStorageID());
{code}

Since in trunk, the reference will be released in the block scanner.

> Rename FsVolumeListTest to TestFsVolumeList and commit it to branch-2
> ---------------------------------------------------------------------
>
>                 Key: HDFS-7778
>                 URL: https://issues.apache.org/jira/browse/HDFS-7778
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: datanode
>    Affects Versions: 2.6.0
>            Reporter: Lei (Eddy) Xu
>            Assignee: Lei (Eddy) Xu
>         Attachments: HDFS-7778-branch2.000.patch, HDFS-7778-trunk.000.patch
>
>
> HDFS-7496 mistakenly named {{FsVolumeListTest}}, which causes it out of jenkin tests.
Also it mistakenly removed it from branch-2 patch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message