hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7761) cleanup unnecssary code logic in LocatedBlock
Date Thu, 12 Feb 2015 14:26:35 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7761?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14318261#comment-14318261
] 

Hudson commented on HDFS-7761:
------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk #2034 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/2034/])
HDFS-7761. cleanup unnecssary code logic in LocatedBlock. (yliu) (yliu: rev 8a54384a0a85b466284fe5717b1dea0a2f29ec8d)
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/DatanodeInfoWithStorage.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/DatanodeManager.java
* hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/LocatedBlock.java


> cleanup unnecssary code logic in LocatedBlock
> ---------------------------------------------
>
>                 Key: HDFS-7761
>                 URL: https://issues.apache.org/jira/browse/HDFS-7761
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.7.0
>            Reporter: Yi Liu
>            Assignee: Yi Liu
>            Priority: Minor
>             Fix For: 2.7.0
>
>         Attachments: HDFS-7761.001.patch, HDFS-7761.002.patch
>
>
> # The usage of following two variables is unnecessary. We can remove them to make code
a bit brief.
> {quote}
> private final boolean hasStorageIDs;
> private final boolean hasStorageTypes;
> {quote}
> # In HDFS-7647, no need to modify {{LocatedBlock#getStorageTypes}} and {{LocatedBlock#getStorageIDs}},
we just need to update the cached {{storageIDs}} and {{storageTypes}} after *sort*.
> # Another thing is we'd better setSoftwareVersion when constructing {{DatanodeInfoWithStorage}}
from {{DatanodeInfo}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message