hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7761) cleanup unnecssary code logic in LocatedBlock
Date Tue, 10 Feb 2015 17:52:12 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7761?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14314522#comment-14314522

Hadoop QA commented on HDFS-7761:

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  against trunk revision e0ec071.

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:red}-1 findbugs{color}.  The patch appears to introduce 1 new Findbugs (version
2.0.3) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:red}-1 core tests{color}.  The following test timeouts occurred in hadoop-hdfs-project/hadoop-hdfs:


Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9516//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/9516//artifact/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9516//console

This message is automatically generated.

> cleanup unnecssary code logic in LocatedBlock
> ---------------------------------------------
>                 Key: HDFS-7761
>                 URL: https://issues.apache.org/jira/browse/HDFS-7761
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.7.0
>            Reporter: Yi Liu
>            Assignee: Yi Liu
>            Priority: Minor
>         Attachments: HDFS-7761.001.patch, HDFS-7761.002.patch
> # The usage of following two variables is unnecessary. We can remove them to make code
a bit brief.
> {quote}
> private final boolean hasStorageIDs;
> private final boolean hasStorageTypes;
> {quote}
> # In HDFS-7647, no need to modify {{LocatedBlock#getStorageTypes}} and {{LocatedBlock#getStorageIDs}},
we just need to update the cached {{storageIDs}} and {{storageTypes}} after *sort*.
> # Another thing is we'd better setSoftwareVersion when constructing {{DatanodeInfoWithStorage}}
from {{DatanodeInfo}}

This message was sent by Atlassian JIRA

View raw message