hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7743) Code cleanup of BlockInfo and rename BlockInfo to BlockReplicationInfo
Date Sat, 07 Feb 2015 01:47:34 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7743?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14310417#comment-14310417
] 

Hadoop QA commented on HDFS-7743:
---------------------------------

{color:green}+1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12697149/HDFS-7743.002.patch
  against trunk revision da2fb2b.

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 21 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
2.0.3) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9468//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9468//console

This message is automatically generated.

> Code cleanup of BlockInfo and rename BlockInfo to BlockReplicationInfo
> ----------------------------------------------------------------------
>
>                 Key: HDFS-7743
>                 URL: https://issues.apache.org/jira/browse/HDFS-7743
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>            Reporter: Jing Zhao
>            Assignee: Jing Zhao
>            Priority: Minor
>         Attachments: HDFS-7743.000.patch, HDFS-7743.001.patch, HDFS-7743.002.patch
>
>
> In the work of erasure coding (HDFS-7285), we plan to extend the class BlockInfo to two
subclasses: BlockReplicationInfo and BlockGroupInfo (HDFS-7716). To ease the HDFS-EC branch
syncing with trunk, this jira plans to rename the current BlockInfo to BlockReplicationInfo
in trunk. In the meanwhile, we can also use this chance to do some minor code cleanup.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message