hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-7743) Code cleanup of BlockInfo and rename BlockInfo to BlockReplicationInfo
Date Fri, 06 Feb 2015 18:55:35 GMT

     [ https://issues.apache.org/jira/browse/HDFS-7743?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jing Zhao updated HDFS-7743:
----------------------------
    Attachment: HDFS-7743.000.patch

The first patch mainly does the rename and removes the unnecessary overrided methods from
BlockInfo.

> Code cleanup of BlockInfo and rename BlockInfo to BlockReplicationInfo
> ----------------------------------------------------------------------
>
>                 Key: HDFS-7743
>                 URL: https://issues.apache.org/jira/browse/HDFS-7743
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>            Reporter: Jing Zhao
>            Assignee: Jing Zhao
>            Priority: Minor
>         Attachments: HDFS-7743.000.patch
>
>
> In the work of erasure coding (HDFS-7285), we plan to extend the class BlockInfo to two
subclasses: BlockReplicationInfo and BlockGroupInfo (HDFS-7716). To ease the HDFS-EC branch
syncing with trunk, this jira plans to rename the current BlockInfo to BlockReplicationInfo
in trunk.
> In the meanwhile, we can also use this chance to do some minor code cleanup. E.g., removing
unnecessary overrided {{hashCode}} and {{equals}} methods since they are just the same with
the super class {{Block}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message