hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7411) Refactor and improve decommissioning logic into DecommissionManager
Date Tue, 10 Feb 2015 23:46:13 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7411?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14315197#comment-14315197
] 

Andrew Wang commented on HDFS-7411:
-----------------------------------

Nicholas, could you please address my proposals about how to translate the old config into
the new config? If you're okay removing the old code in a later 2.x release, then we still
need to agree on compatibility now. As I said above, I struggle to see downsides from a user
point of view. The example you gave exhibits surprising behavior, but it's a pleasant surprise.
It's like finding presents under the tree on Christmas day.

Same for my question about testing. If the concern is code quality, let's think up some more
testing.

As this has already been reviewed by two people, I still feel like a patch split to ease review
is a strange request. -1 on an already +1'd patch because it doesn't split a refactor would
be quite novel.

We're all buds, so I can do a split as a show of good faith, but I'd like agreement on the
above two questions first.

> Refactor and improve decommissioning logic into DecommissionManager
> -------------------------------------------------------------------
>
>                 Key: HDFS-7411
>                 URL: https://issues.apache.org/jira/browse/HDFS-7411
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.5.1
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
>         Attachments: hdfs-7411.001.patch, hdfs-7411.002.patch, hdfs-7411.003.patch, hdfs-7411.004.patch,
hdfs-7411.005.patch, hdfs-7411.006.patch, hdfs-7411.007.patch, hdfs-7411.008.patch, hdfs-7411.009.patch,
hdfs-7411.010.patch
>
>
> Would be nice to split out decommission logic from DatanodeManager to DecommissionManager.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message