hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo Nicholas Sze (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7411) Refactor and improve decommissioning logic into DecommissionManager
Date Tue, 10 Feb 2015 22:46:11 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7411?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14315112#comment-14315112
] 

Tsz Wo Nicholas Sze commented on HDFS-7411:
-------------------------------------------

> ... Heh; I don't think you intended to float this as a precondition for commit.

No. I just want to point out that keeping the existing code is important.

> ... the patch has received a fair amount of review. ...

It does not seem the case to me since no one ever commented on the incompatible change earlier.

The block base approach does sound a good idea to me.  I never object adding it.  However,
as we generally cannot guarantee any new code to be perfect and the new approach can solve
the old problems, we should keep the existing code for the existing conf.  The existing code
can be removed after one or two releases.

Also, I insist to have a simple refactoring patch before adding the new code because the refactoring
patch is going to be very easily reviewed.  The patch with the new code will be smaller and
more easier to understand.

> Refactor and improve decommissioning logic into DecommissionManager
> -------------------------------------------------------------------
>
>                 Key: HDFS-7411
>                 URL: https://issues.apache.org/jira/browse/HDFS-7411
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.5.1
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
>         Attachments: hdfs-7411.001.patch, hdfs-7411.002.patch, hdfs-7411.003.patch, hdfs-7411.004.patch,
hdfs-7411.005.patch, hdfs-7411.006.patch, hdfs-7411.007.patch, hdfs-7411.008.patch, hdfs-7411.009.patch,
hdfs-7411.010.patch
>
>
> Would be nice to split out decommission logic from DatanodeManager to DecommissionManager.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message