hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dongming Liang (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (HDFS-1522) Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant
Date Thu, 12 Feb 2015 17:02:12 GMT

     [ https://issues.apache.org/jira/browse/HDFS-1522?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dongming Liang reassigned HDFS-1522:
------------------------------------

    Assignee: Dongming Liang

> Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant
> ---------------------------------------------------------------------------------
>
>                 Key: HDFS-1522
>                 URL: https://issues.apache.org/jira/browse/HDFS-1522
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: datanode
>    Affects Versions: 0.21.0
>            Reporter: Konstantin Shvachko
>            Assignee: Dongming Liang
>
> Two semantically identical constant {{Block.BLOCK_FILE_PREFIX}} and {{DataStorage.BLOCK_FILE_PREFIX}}
should merged into one. Should be defined in {{Block}}, imo.
> Also use cases of "blok_", like in {{DirectoryScanner}} should be replaced by the this
constant.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message