hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7600) Refine hdfs admin classes to reuse common code
Date Mon, 12 Jan 2015 21:59:36 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7600?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14274242#comment-14274242

Hadoop QA commented on HDFS-7600:

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  against trunk revision ae7bf31.

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
2.0.3) warnings.

        {color:red}-1 release audit{color}.  The applied patch generated 1 release audit warnings.

    {color:red}-1 core tests{color}.  The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:


Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9186//testReport/
Release audit warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/9186//artifact/patchprocess/patchReleaseAuditProblems.txt
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9186//console

This message is automatically generated.

> Refine hdfs admin classes to reuse common code
> ----------------------------------------------
>                 Key: HDFS-7600
>                 URL: https://issues.apache.org/jira/browse/HDFS-7600
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: tools
>            Reporter: Yi Liu
>            Assignee: Jing Zhao
>         Attachments: HDFS-7600.000.patch, HDFS-7600.001.patch
> As the review comment in HDFS-7323. 
> In {{StoragePolicyAdmin}} and other class under {{org.apache.hadoop.hdfs.tools}}, such
as {{CacheAdmin}}, {{CryptoAdmin}}. There are too many common methods ({{getDFS}}, {{prettifyException}},
{{getOptionDescriptionListing}} ...) and also inner class ({{HelpCommand}}), they are the
same, it would be great if we can refine and shift them into a common place.
> This makes the code clean and can be re-used if we add new hdfs admin class in future.

This message was sent by Atlassian JIRA

View raw message