hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7550) Minor followon cleanups from HDFS-7543
Date Fri, 19 Dec 2014 23:44:19 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7550?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14254268#comment-14254268

Hadoop QA commented on HDFS-7550:

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  against trunk revision d9e4d67.

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:red}-1 findbugs{color}.  The patch appears to introduce 1 new Findbugs (version
2.0.3) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:red}-1 core tests{color}.  The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:


Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9096//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/9096//artifact/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9096//console

This message is automatically generated.

> Minor followon cleanups from HDFS-7543
> --------------------------------------
>                 Key: HDFS-7550
>                 URL: https://issues.apache.org/jira/browse/HDFS-7550
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>    Affects Versions: 2.7.0
>            Reporter: Charles Lamb
>            Priority: Minor
>         Attachments: HDFS-7550.001.patch
> The commit of HDFS-7543 crossed paths with these comments:
> FSDirMkdirOp.java
> in #mkdirs, you removed the final String srcArg = src. This should be left in. Many IDEs
will whine about making assignments to formal args and that's why it was put in in the first
> FSDirRenameOp.java
> #renameToInt, dstIIP (and resultingStat) could benefit from final's.
> FSDirXAttrOp.java
> I'm not sure why you've moved the call to getINodesInPath4Write and checkXAttrChangeAccess
inside the writeLock.
> FSDirStatAndListing.java
> The javadoc for the @param src needs to be changed to reflect that it's an INodesInPath,
not a String. Nit: it might be better to rename the INodesInPath arg from src to iip.
> #getFileInfo4DotSnapshot is now unused since you in-lined it into #getFileInfo.

This message was sent by Atlassian JIRA

View raw message