hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7317) Rename StoragePolicy
Date Fri, 31 Oct 2014 21:33:34 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7317?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14192530#comment-14192530

Suresh Srinivas commented on HDFS-7317:

Some clarifications:
Storage Policies today are: hot, warm, cold, one_ssd, all_ssd
These names also have corresponding replication placement mechanism (which was configurable,
but we have disabled that configurability). The mechanism indicates which storage type different
replicas are placed.

As I indicated in the discussion today, we have list of policies and corresponding implementation
of what that policy means. Given that I do not see what this rename is buying and how it is
relevant to erasure coding. One thing I took away was, perhaps only placement as a mechanism
is limiting.

> Rename StoragePolicy
> --------------------
>                 Key: HDFS-7317
>                 URL: https://issues.apache.org/jira/browse/HDFS-7317
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.6.0
>            Reporter: Andrew Wang
> As discussed on HDFS-7285, StoragePolicy might not be the best name for what StoragePolicy
currently is, which is a hardcoded mapping to a StorageType. Ideally the "policy" is what
determines the data temperature in the first place, with the temperature then mapping to the
actual StorageTypes to use.
> There were a number of suggestions presented, e.g. StorageTag, StoragePolicyTag. Let's
figure this out here.

This message was sent by Atlassian JIRA

View raw message