hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-7317) Rename StoragePolicy
Date Fri, 31 Oct 2014 21:05:34 GMT
Andrew Wang created HDFS-7317:
---------------------------------

             Summary: Rename StoragePolicy
                 Key: HDFS-7317
                 URL: https://issues.apache.org/jira/browse/HDFS-7317
             Project: Hadoop HDFS
          Issue Type: Improvement
    Affects Versions: 2.6.0
            Reporter: Andrew Wang


As discussed on HDFS-7285, StoragePolicy might not be the best name for what StoragePolicy
currently is, which is a hardcoded mapping to a StorageType. Ideally the "policy" is what
determines the data temperature in the first place, with the temperature then mapping to the
actual StorageTypes to use.

There were a number of suggestions presented, e.g. StorageTag, StoragePolicyTag. Let's figure
this out here.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message