hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7200) Rename libhdfs3 to libndfs++
Date Fri, 10 Oct 2014 19:54:34 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14167402#comment-14167402

Colin Patrick McCabe commented on HDFS-7200:

bq. And under my impression (please correct me if I'm wrong), at least for the first phase
the library might need to fall back to Java for the writes, thus the claim of the library
is fully native might be somewhat confusing.

I think that in the HDFS-6994 branch, we should focus on stabilizing the libhdfs3 code and
getting it in shape to go upstream.  It would be nice to provide the "fallback to JNI" functionality,
but I don't think we need to do this pre-merge since there are a lot of other things to do.
 I've posted a JIRA for the fallback functionality at HDFS-7041, and would appreciate reviews
and discussion there.  I think we can keep fallback functionality separate from the main library
for now, similar to how {{JniBasedUnixGroupsMappingWithFallback}} is separate from {{JniBasedUnixGroupsMapping}}.

bq. I don't have a strong opinion about the names, but I'm slight leaning towards libhdfs++
since it saves the effort of educating the users what ndfs means, as well as the effort on
establishing the brand of ndfs.

The problem is that users do need to be educated.  For example, if a user tries to use libhdfs3
and it fails because that user required S3 functionality, then having confusingly similar
names is a bad thing.  This is the same reason why {{ShellBasedUnixGroupsMapping}} and {{JniBasedUnixGroupsMapping}}
have different names.  If we decided to refer to {{JniBasedUnixGroupsMapping}} as {{ShellBasedUnixGroupsMapping3}},
it would obviously lead to user confusion.

> Rename libhdfs3 to libndfs++
> ----------------------------
>                 Key: HDFS-7200
>                 URL: https://issues.apache.org/jira/browse/HDFS-7200
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: hdfs-client
>    Affects Versions: HADOOP-10388
>            Reporter: Colin Patrick McCabe
>            Assignee: Colin Patrick McCabe
>         Attachments: HDFS-7200.001.patch
> Since we generally agree that libhdfs3 is a sub-optimal name, let's call the new library

This message was sent by Atlassian JIRA

View raw message