hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haohui Mai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7200) Rename libhdfs3 to libndfs++
Date Fri, 10 Oct 2014 19:43:34 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14167381#comment-14167381
] 

Haohui Mai commented on HDFS-7200:
----------------------------------

I don't have a strong opinion about the names,  but I'm slight leaning towards libhdfs++ since
it saves the effort of educating the users what ndfs means, as well as the effort on establishing
the brand of ndfs.

And under my impression (please correct me if I'm wrong), at least for the first phase the
library might need to fall back to Java for the writes, thus the claim of the library is fully
native might be somewhat confusing.

[~cmccabe], what do you think?

> Rename libhdfs3 to libndfs++
> ----------------------------
>
>                 Key: HDFS-7200
>                 URL: https://issues.apache.org/jira/browse/HDFS-7200
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: hdfs-client
>    Affects Versions: HADOOP-10388
>            Reporter: Colin Patrick McCabe
>            Assignee: Colin Patrick McCabe
>         Attachments: HDFS-7200.001.patch
>
>
> Since we generally agree that libhdfs3 is a sub-optimal name, let's call the new library
"libndfs++."



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message