hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kihwal Lee (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7117) Not all datanodes are displayed on the namenode http tab
Date Tue, 23 Sep 2014 17:09:33 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7117?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14145045#comment-14145045
] 

Kihwal Lee commented on HDFS-7117:
----------------------------------

I assume you saw this in 2.4. Have you tried branch-2 or release-2.5.*? There have been multiple
fixes around the UI since 2.4.

> Not all datanodes are displayed on the namenode http tab
> --------------------------------------------------------
>
>                 Key: HDFS-7117
>                 URL: https://issues.apache.org/jira/browse/HDFS-7117
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: namenode
>            Reporter: Jean-Baptiste Onofré
>             Fix For: 2.4.0
>
>
> On a single machine, I have three "fake nodes" (each node use different dfs.datanode.address,
dfs.datanode.ipc.address, dfs.datanode.http.address)
> - node1 starts the namenode and a datanode
> - node2 starts a datanode
> - node3 starts a datanode
> In the namenode http console, on the overview, I can see 3 live nodes:
> {code}
> http://localhost:50070/dfshealth.html#tab-overview
> {code}
> but, when clicking on the "Live Nodes":
> {code}
> http://localhost:50070/dfshealth.html#tab-datanode
> {code}
> I can see only one node row.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message