hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7104) Fix and clarify INodeInPath getter functions
Date Mon, 29 Sep 2014 20:12:36 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7104?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14152197#comment-14152197
] 

Hudson commented on HDFS-7104:
------------------------------

FAILURE: Integrated in Hadoop-trunk-Commit #6143 (See [https://builds.apache.org/job/Hadoop-trunk-Commit/6143/])
HDFS-7104. Fix and clarify INodeInPath getter functions. Contributed by Zhe Zhang. (wang:
rev f0293f11a85176afc04d809574c9126a80b700cc)
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodesInPath.java
* hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestSnapshotPathINodes.java


> Fix and clarify INodeInPath getter functions
> --------------------------------------------
>
>                 Key: HDFS-7104
>                 URL: https://issues.apache.org/jira/browse/HDFS-7104
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Zhe Zhang
>            Assignee: Zhe Zhang
>            Priority: Minor
>             Fix For: 2.6.0
>
>         Attachments: HDFS-7104-20140923-v1.patch, HDFS-7104-20140923-v3.patch, HDFS-7104-20140924-v1.patch,
HDFS-7104-20140924-v2.patch, HDFS-7104-20140924-v3.patch
>
>
> inodes is initialized with the number of patch components. After resolve, it contains
both non-null and null elements (introduced by dot-snapshot dirs).
> When getINodes is called, an array is returned excluding all non elements, which is the
correct behavior. Meanwhile, the inodes array is trimmed too, which shouldn't be done by a
getter.
> Because of the above, the behavior of getINodesInPath depends on whether getINodes has
been called, which is not correct.
> The name of getLastINodeInPath is confusing – it actually returns the last non-null
inode in the path. Also, shouldn't the return type be a single INode?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message