hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-7055) Add tracing to DFSInputStream
Date Tue, 23 Sep 2014 18:46:34 GMT

    [ https://issues.apache.org/jira/browse/HDFS-7055?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14145221#comment-14145221

stack commented on HDFS-7055:

bq. One thing to keep in mind here is that if you call Trace.startSpan with Sampler.NEVER,
and there is an existing thread trace span, a subspan will always be created. 

Thanks for mentioning this up front... first thing I stumbled on looking in code. Its a little
confusing but having a comment to explain NEVER in every span open, it'll get annoying fast.

Nit: This exception, if it possible to ask trace for the list of options, should list the
possible options (I can see folks typing in sampler with wrong case or missing a piece...
listing possible options will allow them quickly see what they have done wrong):

+      throw new RuntimeException("Can't create sampler " + samplerStr);

Nit: Should we have a convention naming spans [~cmccabe]?  For example, method name followed
by arg types all in camel case?

+        dfsClient.getTraceScope("byteBufferRead", src);

... would become readByteBuffer and +        dfsClient.getTraceScope("byteArrayRead", src);
would be readByteArrayIntInt?

Patch looks great to me. You gotten any spans out of it?  I can try it if you'd like, no problem.

> Add tracing to DFSInputStream
> -----------------------------
>                 Key: HDFS-7055
>                 URL: https://issues.apache.org/jira/browse/HDFS-7055
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: 2.6.0
>            Reporter: Colin Patrick McCabe
>            Assignee: Colin Patrick McCabe
>         Attachments: HDFS-7055.002.patch
> Add tracing to DFSInputStream.

This message was sent by Atlassian JIRA

View raw message