hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6837) Code cleanup for Balancer and Dispatcher
Date Tue, 12 Aug 2014 15:59:15 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6837?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14094217#comment-14094217
] 

Hudson commented on HDFS-6837:
------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk #1835 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/1835/])
HDFS-6837. Code cleanup for Balancer and Dispatcher. Contributed by Tsz Wo Nicholas Sze. (jing9:
http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1617337)
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/balancer/Balancer.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/balancer/Dispatcher.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/balancer/ExitStatus.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/balancer/TestBalancer.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/balancer/TestBalancerWithHANameNodes.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/balancer/TestBalancerWithMultipleNameNodes.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/balancer/TestBalancerWithNodeGroup.java


> Code cleanup for Balancer and Dispatcher
> ----------------------------------------
>
>                 Key: HDFS-6837
>                 URL: https://issues.apache.org/jira/browse/HDFS-6837
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: balancer
>            Reporter: Tsz Wo Nicholas Sze
>            Assignee: Tsz Wo Nicholas Sze
>            Priority: Minor
>             Fix For: 2.6.0
>
>         Attachments: h6837_20140810.patch, h6837_20140810b.patch
>
>
> A few minor code cleanup changes:
> - The constructor of Dispatcher should not read Balancer's conf properties; the values
should be passed by parameters.
> - StorageGroup.utilization can be removed; it is only used in toString().
> - Move Balancer.ReturnStatus to a standalone class.
> - In Dispatcher, rename BalancerDatanode to DDatanode.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message