hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo Nicholas Sze (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-6837) Code cleanup for Balancer and Dispatcher
Date Sun, 10 Aug 2014 04:04:12 GMT

     [ https://issues.apache.org/jira/browse/HDFS-6837?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tsz Wo Nicholas Sze updated HDFS-6837:
--------------------------------------

    Status: Patch Available  (was: Open)

> Code cleanup for Balancer and Dispatcher
> ----------------------------------------
>
>                 Key: HDFS-6837
>                 URL: https://issues.apache.org/jira/browse/HDFS-6837
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: balancer
>            Reporter: Tsz Wo Nicholas Sze
>            Assignee: Tsz Wo Nicholas Sze
>            Priority: Minor
>         Attachments: h6837_20140810.patch
>
>
> A few minor code cleanup changes:
> - The constructor of Dispatcher should not read Balancer's conf properties; the values
should be passed by parameters.
> - StorageGroup.utilization can be removed; it is only used in toString().
> - Move Balancer.ReturnStatus to a standalone class.
> - In Dispatcher, rename BalancerDatanode to DDatanode.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message