hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tassapol Athiapinya (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-5887) Add suffix to generated protobuf class
Date Thu, 14 Aug 2014 15:24:12 GMT

     [ https://issues.apache.org/jira/browse/HDFS-5887?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tassapol Athiapinya updated HDFS-5887:
--------------------------------------

    Attachment: HDFS-5887.001.patch

Jenkins did not pick up right patch. Attaching 001.patch to tell Jenkins to pick complete
patch.

> Add suffix to generated protobuf class
> --------------------------------------
>
>                 Key: HDFS-5887
>                 URL: https://issues.apache.org/jira/browse/HDFS-5887
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>    Affects Versions: HDFS-5698 (FSImage in protobuf)
>            Reporter: Haohui Mai
>            Assignee: Tassapol Athiapinya
>            Priority: Minor
>         Attachments: HDFS-5887.000.patch, HDFS-5887.000.proto_files-only.patch, HDFS-5887.001.patch
>
>
> As suggested by [~tlipcon], the code is more readable if we give each class generated
by the protobuf the suffix "Proto".
> This jira proposes to rename the classes and to introduce no functionality changes.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message