hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tassapol Athiapinya (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5887) Add suffix to generated protobuf class
Date Wed, 13 Aug 2014 04:59:16 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5887?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14095151#comment-14095151
] 

Tassapol Athiapinya commented on HDFS-5887:
-------------------------------------------

[~wheat9] Is the jira still valid? In *.proto, java_outer_classname is already suffixed with
either "Proto" or "Protos".

> Add suffix to generated protobuf class
> --------------------------------------
>
>                 Key: HDFS-5887
>                 URL: https://issues.apache.org/jira/browse/HDFS-5887
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>    Affects Versions: HDFS-5698 (FSImage in protobuf)
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>            Priority: Minor
>
> As suggested by [~tlipcon], the code is more readable if we give each class generated
by the protobuf the suffix "Proto".
> This jira proposes to rename the classes and to introduce no functionality changes.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message