hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6787) Remove duplicate code in FSDirectory#unprotectedConcat
Date Wed, 30 Jul 2014 15:23:38 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6787?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14079372#comment-14079372
] 

Hadoop QA commented on HDFS-6787:
---------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12658636/HDFS-6787.001.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
2.0.3) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/7495//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7495//console

This message is automatically generated.

> Remove duplicate code in FSDirectory#unprotectedConcat
> ------------------------------------------------------
>
>                 Key: HDFS-6787
>                 URL: https://issues.apache.org/jira/browse/HDFS-6787
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: namenode
>    Affects Versions: 3.0.0
>            Reporter: Yi Liu
>            Assignee: Yi Liu
>         Attachments: HDFS-6787.001.patch
>
>
> {code}
> // update inodeMap
> removeFromInodeMap(Arrays.asList(allSrcInodes));
> {code}
> this snippet of code is duplicate, since we already have the logic above it:
> {code}
>     for(INodeFile nodeToRemove: allSrcInodes) {
>       if(nodeToRemove == null) continue;
>       
>       nodeToRemove.setBlocks(null);
>       trgParent.removeChild(nodeToRemove, trgLatestSnapshot);
>       inodeMap.remove(nodeToRemove);
>       count++;
>     }
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message