hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6627) Rename DataNode#checkWriteAccess to checkReadAccess.
Date Wed, 09 Jul 2014 11:33:06 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6627?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14056123#comment-14056123
] 

Hudson commented on HDFS-6627:
------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk #1799 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/1799/])
HDFS-6627. Rename DataNode#checkWriteAccess to checkReadAccess. Contributed by Liang Xie.
(cnauroth: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1608940)
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java


> Rename DataNode#checkWriteAccess to checkReadAccess.
> ----------------------------------------------------
>
>                 Key: HDFS-6627
>                 URL: https://issues.apache.org/jira/browse/HDFS-6627
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode
>    Affects Versions: 3.0.0, 2.5.0
>            Reporter: Liang Xie
>            Assignee: Liang Xie
>             Fix For: 3.0.0, 2.6.0
>
>         Attachments: HDFS-6627.txt
>
>
> Just read getReplicaVisibleLength() code and found it, DataNode.checkWriteAccess is only
invoked by DataNode.getReplicaVisibleLength(), let's rename it to checkReadAccess to avoid
confusing, since the real impl here is check AccessMode.READ:
> {code}
>         blockPoolTokenSecretManager.checkAccess(id, null, block,
>             BlockTokenSecretManager.AccessMode.READ);
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message