hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-6627) Rename DataNode#checkWriteAccess to checkReadAccess.
Date Tue, 08 Jul 2014 20:28:06 GMT

     [ https://issues.apache.org/jira/browse/HDFS-6627?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Nauroth updated HDFS-6627:
--------------------------------

    Summary: Rename DataNode#checkWriteAccess to checkReadAccess.  (was: getReplicaVisibleLength()
should do checkReadAccess insteading of checkWriteAccess)

> Rename DataNode#checkWriteAccess to checkReadAccess.
> ----------------------------------------------------
>
>                 Key: HDFS-6627
>                 URL: https://issues.apache.org/jira/browse/HDFS-6627
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode
>    Affects Versions: 3.0.0, 2.5.0
>            Reporter: Liang Xie
>            Assignee: Liang Xie
>         Attachments: HDFS-6627.txt
>
>
> Just read getReplicaVisibleLength() code and found it, DataNode.checkWriteAccess is only
invoked by DataNode.getReplicaVisibleLength(), let's rename it to checkReadAccess to avoid
confusing, since the real impl here is check AccessMode.READ:
> {code}
>         blockPoolTokenSecretManager.checkAccess(id, null, block,
>             BlockTokenSecretManager.AccessMode.READ);
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message