hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo Nicholas Sze (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6562) Refactor rename() in FSDirectory
Date Tue, 24 Jun 2014 00:10:24 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6562?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14041507#comment-14041507
] 

Tsz Wo Nicholas Sze commented on HDFS-6562:
-------------------------------------------

Thanks for the explanation.  Returning false sounds good.

For the new patch,
- There are two "srcChild = srcIIP.getLastINode()" in the RenameOperation constructor.
- The field srcRefDstSnapshot can be changed to final.

> Refactor rename() in FSDirectory
> --------------------------------
>
>                 Key: HDFS-6562
>                 URL: https://issues.apache.org/jira/browse/HDFS-6562
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>         Attachments: HDFS-6562.000.patch, HDFS-6562.001.patch, HDFS-6562.002.patch, HDFS-6562.003.patch,
HDFS-6562.004.patch, HDFS-6562.005.patch, HDFS-6562.006.patch
>
>
> Currently there are two variants of {{rename()}} sitting in {{FSDirectory}}. Both implementation
shares quite a bit of common code.
> This jira proposes to clean up these two variants and extract the common code.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message