hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haohui Mai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6562) Refactor rename() in FSDirectory
Date Mon, 23 Jun 2014 22:48:25 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6562?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14041440#comment-14041440

Haohui Mai commented on HDFS-6562:

Uploaded v6 patch to address [~szetszwo]'s comments.

The changes about the symlinks are intentional. Please correct me if I'm wrong, but it looks
to me that the old rename prefers to returning {{false}} instead of throwing exceptions. We
can change this behavior without introducing backward compatibility issues since symlink is
only available in trunk.

> Refactor rename() in FSDirectory
> --------------------------------
>                 Key: HDFS-6562
>                 URL: https://issues.apache.org/jira/browse/HDFS-6562
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>         Attachments: HDFS-6562.000.patch, HDFS-6562.001.patch, HDFS-6562.002.patch, HDFS-6562.003.patch,
HDFS-6562.004.patch, HDFS-6562.005.patch, HDFS-6562.006.patch
> Currently there are two variants of {{rename()}} sitting in {{FSDirectory}}. Both implementation
shares quite a bit of common code.
> This jira proposes to clean up these two variants and extract the common code.

This message was sent by Atlassian JIRA

View raw message