hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6480) Move waitForReady() from FSDirectory to FSNamesystem
Date Tue, 17 Jun 2014 22:33:07 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6480?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14034503#comment-14034503
] 

Jing Zhao commented on HDFS-6480:
---------------------------------

The patch looks good to me. Some comments:
# I think the change will make more sense after we move the fsimage reference from FSDirectory
to FSNamesystem, because only after that can the FSDirectory become a pure in-memory data
structure for namespace. But feel free to do it in a separate jira.
# We may want to update the javadoc for FSDirectory.
# It will be better to rename ready and waitReady etc. to something like fsdirLoaded etc.
# TestFSDirectory#testReset should be moved to TestFSNamesystem and renamed to testResetFSDirectory.

> Move waitForReady() from FSDirectory to FSNamesystem
> ----------------------------------------------------
>
>                 Key: HDFS-6480
>                 URL: https://issues.apache.org/jira/browse/HDFS-6480
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>         Attachments: HDFS-6480.000.patch, HDFS-6480.001.patch, HDFS-6480.002.patch
>
>
> Currently FSDirectory implements a barrier in {{waitForReady()}} / {{setReady()}} so
that it only serve requests once the FSImage is fully loaded.
> As a part of the effort to evolve {{FSDirectory}} to a class which focuses on implementing
the data structure of the namespace, this jira proposes to move the barrier one level higher
to {{FSNamesystem}}.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message